ECE ILLINOIS

ECE 451: Ansys HFSS Tutorial

Simulate and Analyze an Example of Microstrip Line

Drew Handler , Jerry Yang

October 20, 2014

ECE ILLINOIS Ticrinors



Introduction

= ANSYS HFSS is an industry standard tool for
simulating 3-D full-wave electromagnetic fields.

= Students registered in ECE451 can get free access
to ANSYS HF package from the University of lllinois
Software Webstore.

= Follow the installation guide* to install the software
on your PC.

*Note: You will need to e-mail your computer name and a copy of the purchase
receipt to webstore@illinois.edu. Allow 1-2 business days for your computer to be

added to the license pool.

ECE ILLINOIS TitriNnoTs



Getting Started

= | aunch HFSS: msmqso.m. -
—  Start>All Programs=>ANSYS | .-
Electromagnetics2>HFSS S
15.0->Windows 64-bit (or 32- ¥ Incse forte maor
b|t) 9 H F S S 1 5 O Solve Inside threshold: 100000 [Siemens/m |
— Assignment Options
[ Set H FSS Optlons: ¥ UUse Wizards for data input when creating new boundaries
W Duplicate boundaries/mesh operations with geometry.
- Tools>Options2>HFSS ¥ Vissizeboundaris o geamety
Options>General Tab 7 Mo
: Check v'Use Wizards for data input | o
when creating new boundaries ek e o [fsconng parunese ]
. Check v'Duplicate boundaries/mesh P
operations with geometry [ Save Optimetrics field soluions.
° C| |Ck OK [T Apply variation deletions immediately.
[ ok | Ccancel
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Getting Started

= Set Modeler OptioNS: " o o | o] S ——

a —Clane — Snap Mode
— TOO I S % O pt I O n S- [~ Clone tool objects before uniting v Grid
eMOdeIer Optlons ™ Clone tool objects before subtracting W Vertex
. [™ Clone tool objects before intersecting [ | Edae Center
- O pe rat I O n Ta.b [~ Clone tool objects before imprinting 7 Facg:e Center
° C h eC k [” Clone tool objects before projecting ¥ Quadrant
. —Coordinate System
/Au.tomatl Cal Iy [ Automatically switch to face coordinate system u
cover closed o Mouse Serstvty: [F oo
po Iyl | n eS v Astomatically cover closed pobylines ¥ Showmeasue didog
d CheCk ‘/SeleCt R Operation Data Entry Mode
¥ Delete invalid objects created during split operation
last command on  Poit " Db

Automatically imprint wrapped shest
L . lUse F3/F4 to switch between point and dizlog entry mode

object select ’
— History Tree
—_ DraWing Tab ¥ Select last command on object seled)

. [ Expand history tree on object select
» Check v'Edit —
—UDMAUDP geometry computation for optimetrics analysis

p ro pe rtleS Of new ¥ Engine computes the geometry
- - " Deskiop computes the geometry
p rl m ItlveS Geometry computation for models with CAD integration (dynamic links)
. and geometry sharing in ANSY'S Workbench is always by Desktop.
— Click OK

| Edit properties of new primitives

0K I Cancel 0K I Cancel
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Getting Started

" Name Project

— Project 1 is already created by default iDSE|s =@ |8|X

— Right click on Project 1> Rename i;; ’ “~m D ﬂJ |;

— Type a name of your choosing Enn =
(helloHFSS, ECE451, tutorial, etc.) ~& ECEA51 tutoria

--@ Microstrip (DrivenMod

= New HFSS eﬁnmm

— Right click on your
project-> Insert-> Insert HFSS Design /

— Rename the HFSS Design as microstrip
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Getting Started

= Set the solution type: -
— Click on HFSS->Solution Type E & Ve
— Select Modal  igonmode
— Click OK o | oo

= Set Model Unit:
— Click on Modeler->Units -
— Select mil from the drop down menu T fesssetonmmun
_ Click OK ] o |
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Creating the Microstrip

We are going to make the substrate (a.k.a
dielectric layer), ground plane, and copper trace
(conductor) for a microstrip line.

http://emlab.uiuc.edu/ece451/appnotes/planar structures.pdf

To do this, we will make three “boxes” in HFSS,
and then designate the appropriate dimensions
and material for each box.
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Creating the Microstrip

First we are going to define several variables for
the dimensions of our substrate, ground plane, and

copper trace
— Select HFSS—>Design Properties->Add

— Fill in the properties as shown below

[ Add Property — - —— - =5
Marne |micrnstri|:|_L % ‘ariable " Separatar " PostProcessing ariable
" Amraylndesy aniable
Unit Tupe ILenglh j Urits Imil j
Walue | 1000

Enter a number with unit, variable, or expression inta the Yalue field. Referenced project variables should be prefived with 2 '$. Examples: 22.4pF, $C1,

Fooz($n).

_ Click OK
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Creating the Microstrip

Repeat the previous steps to create 7 more variables

with the following values:
e Substrate W — 1000 mil
Substrate H - 60 mil
Gnd _H -4 mil
Trace W - 114.7mil
Trace H -4 mil
Waveport W — 419 mil
 Waveport H - 115 mil

Using these variables, we will define a 1.00°x1.00”” board with a 60
mil thick substrate, 4 mil thick ground plane and trace, and 107.4
mil wide trace

**Recall: 1 inch =1000 mil = 25.4mm
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Creating the Microstrip (1): Substrate

Select the Draw Box button

451 tutorial - microstrip - Modeler] . B . [ =
Tools Window Help I;“i"il

iDEH|t2a(a|xoc (5N o iesék|or |8 imcissaelai|led|on 3|88 s8588
igwi~vwiaticooedilglomoace=9or i o 20 vk oo iweld IO0B ibaad i
1@ @ I® [ecam Mol o] P faow s 00

|ProjectManager _+ x| 5[, Coordinate

|3¥ ANSYS HFSS - 451 tutorial - microstrip - 30
B File Edit View Project Draw Modeler HF

i 4
tutorial™ (-4 Planes “
microstrip (DrivenTem €D Lists
Definitions
U ==
Project

Properties . x

Name Un

<o 3
Variables < D 0 1 2 (mil)

x x

< .

g

g

5

=

3 §

: 5

H &]

Ready ,_,_NUM ,_
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Creating the Microstrip (1): Substrate

= Once you have selected the draw box, move your
cursor into the window the 3D axis shown

= Click anywhere, move your mouse In the XY plane,
click again, move your mouse in the Z direction, and
click a third time

= You have now created an arbitrary sized box

= Awindow will pop up in which you can define
the dimensions and location of the box

= Fill in the location and dimension as shown below
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Creating the Microstrip (1): Substrate

a hl
Properties: 451_tutoral - microstnp - Modeler M

Command | Attribute |

MName Value Unit | Evaluated Value Description
Command CreateBox
Coordinate Sys...|Global
Position 0.0.0 mil Omil . Ormil , Ornil
| X5ize | substrate_W | 1000mil
YSize 1000mil
ZSize 60mil

™ Show Hidden

| 8] I Cancel
| T |

= Click OK

= You may need to zoom out in order to see your box (scroll down with your
mouse to zoom out)
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Creating the Microstrip (1): Substrate

You should have a box that looks like this

— To change your view Iin 2D, hold Shift + left click and drag
— To change your view in 3D, hold Alt + left click and drag
— To fit the view In the 3D modeler window: Ctrl+D
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Creating the Microstrip (1): Substrate

This box now has the dimensions that we want for our
substrate. The next step is to define the material of our
substrate.

— Double click on “Box1™ and fill in the properties as

shown below | a2

=
iff) Create Bc
@12, Coordinate Systems

— Details on s @ fin
next slide

-y

&
3
9
z
8

a
=

MName Value I Uit IE\raIuated ‘u"aluel Description

Material "FR4_epaomy” "FR4_epaomy”

—I—I—I—I—I—I—I—Ig

LLT T[] T[]
=
&

[~ Show Hidden
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Creating the Microstrip (1): Substrate

— Change the name from Box1 to substrate

— Change the material from vacuum to FR4 _epoxy
 Select Edit from the material drop down menu

 In the Search by Name box, type in fr
— FR4 _epoxy should be highlighted

e Click OK
— Change the color to whatever you want
— Change the transparency to 0.8
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Creating the Microstrip (2): Gnd Plane

Now we are going to make the ground plane

— Draw another arbitrary sized box and fill in the
Iocatlon and dlmensmn as shown below

[ Properie: 451 tulonl i — =5=)
Command |p¢t ibute |
MName | Walue I Unit |E\raluated Value Description I |
Command CreateBox
Coordinate Sys... Global
Posttion mil Ol , Ol Ol
XSize 1000mil
YSize 1 000mil
ZSize il
[~ Show Hidden
QK I Cancel

— Make sure the ground height is negative

» Alternatively, you could make the position 0,0,-gnd_H and keep the ZSize
positive
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Creating the Microstrip (2): Gnd Plane

Now we have our ground plane with the correct
dimensions and location, but still need to change
the material.

e Double click on Box1

e Change the name to gnd_plane

e Change the material to copper

e Change the color

 Make the transparency 0.8
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Creating the Microstrip (3): Trace

The last part of building our microstrip line is to
add the microstrip trace. To do this, create another
box and fill in the location and dimensions as
shown below.

F 4
Properties: 4531 _tutcrial - microstrip - Modeler A u
Command |
MName | Walue | it | Evaluated Value Description | |

Command CreateBox

Coordinate Sys...|Global

Position [substmte_WfE—tmce_WfE .0 substrate_H 442 65mil . 0. 6.

¥Size 114 7mil

Y'Size 1000mil

ZSize 4mil

[T Show Hidden
QK I Cancel
4
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Creating the Microstrip (3): Trace

Again we need to change the material
e Double click on Box1
e Change the name to trace
e Change the material to copper
e Change the color
 Make the transparency 0.8

ECE ILLINOIS TitriNnoTs



Creating the Excitation

Our model for our microstrip line is almost

complete and ready to simulate. We still need to
define the excitation for our model.

e Change the Drawing Plane from XY to ZX

- [451_tutorial - microstrip - Modeler] e

5 Tools Window Help
223 o ieEsdn or B

4ipPPpoCce=9n il o4 |[x =B Aineeo@ ipmoBa I08 b

[ie e e aem & i e 7z

2
iper
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Creating the Excitation

* Draw a rectangle (not a box)

= Double click on create rectangle and fill in the
position and dimensions as shown below

E! FR4_epouxy
G- substrate
=3 Sheets ‘ /
EI:I Unassigned rIJ'rcn;:uarties: 451 _tutorial - microstrip - Modeler u
-3 Rectanglel
;I:I Createﬂectanglel T
...[E CowverLines
&L, Coordinate Systems Name I Value | Unit |E\raluated Value Description I |
Sg EiI:tr;es (= Command CreateRectangle
Coordinate Sys... Global
| Position |Lbst|7:ne W 2awaveport W2 microstip L -gnd H | 250 .5mil , 1000...
R | A ¥
— m *Size waveport_W 415mil
EI m Z5ize waveport_H 1715mil
C
[ Show Hidden
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Creating the Excitation

= Draw a second rectangle

= Double click on create rectangle and fill in the
nosition and dimensions as shown below

|2 RECTANgIEL
----- 1 CreateRectangl | /
-..[H Coverlines p —
-3 Rectangle2 Properties: 451 _tutonal - microstrip - Modeler _ u
|I:I CreateRectangle
...[H Coverlines Command |
|'_—‘|I4 Coordinate Systemns
; - 8 Global MName I Value | Unit IE\raluated Value Description | |
"E Planes Command CreateRectangle
— | B Lists | |Coordinate Sys...|Global
;E\ | |Postion |substrate W/2-waveport W/2 Omil and_H | 290 5mil , Omil , ..
ttec | s Y
[ xsize 415mi
|z 115mil
[T Show Hidden
oK I Cancel
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Creating the Excitation

— Right click rectangle 2-> Assign Excitation->Wave Port
» Wave Port: General — leave the port number 1 and click Next
* Wave Port: Modes — leave default settings and click Next

» Wave Port: Post Processing — select Renormalize All Modes and leave
the Full Port Impedance as 50 Ohms

e Click Finish

zl | (—
Number of Modes: I
—Port Rer lization
Mode I Integration Line I Characteristic Impedance (Zo) Do Not Renomalize
1 MNone Zpi
@ Reromalize Al Modes
Full Port Impedance: 50 form x|
s F'yﬂ"ze Spesitic Modes Edit Made [mpedances.. |
= bed Settings:
Mode Alignment and Polarity: [~ Deembed Distance: (0 Imi\ j
(% Set mode pol ing integration |
mods polarty using integration inss Fositive distance will deembed the port inta the
" Align modes using integration lines
" Miign modes analytically using coordinate system Gt Distance Graphically. |
U Puds. IUndeﬁned ﬂ ™| Reverse Y Direction
™ Fiter modes for reporter LRl
Use Defautt
cBack [ Net> | Cancel Back Cancel | <Back [ Fnsh |  Cancel

— Repeat the steps above to make rectangle 1 Wave Port 2

ECE ILLINOIS

ILLINOIS




Creating the Air Box

HFSS treats the space around your design that
hasn’t been designated as a specific material as
PEC. Because of this, we need to define an airbox
around our design.

* Change the Drawing Plane back from ZX to XY

* Draw a box and fill in the values as shown below

-
Properties: 451 _tutorial - microstrip - Modeler

Command |

Mame I Value I Unit IEvaIuated ‘u’aluel Description I |
Command CreateBox
Coordinate Sys...|Global

| Posiion subsirate W2 0mil -and H | 500mil , Omil . -..
xS [Zsubstrate_W | 2000mil

| vsize microstip_L | 1000mi

: ZSize [0substrste H | £00mil

[ Show Hidden

QK I Cancel
4
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Creating the Air Box

— Double click on Box1
 Rename it as airbox
« Change the material to air
e Change the color
 Make the transparency 0.8
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Add Solution Setup

Click on HFSS-> Analysis Setup->Add Solution Setup

¥ Sol

x|

"General Options | Advanced | Expression Cache | Derivatives | Defauits |

i~ Initial Mesh Options

General Tab: T ase
— Solution Frequency: 10 GHz e
— Maximum Number of Passes: 20 ==

- .
— Maximum Delta S: 0.02 e

Options Tab: S ———

i~ Initial Mesh Options

— Minimum Converged Passes: 2 T

I Use Free Space Lambda

— Adaptive Options

— Order of Basis Function: Zero Order T o

[~ Madmum Refinement: 1000000
Minimum Number of Passes: 1
| Minimum Converged Passes: 2 |

C I I C k O K ™| Enatile Iterative Solver
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Add Frequency Sweep
Click on HFSS-> Analysis Setup-> Add Frequency Sweep
=  Select Setupl and click OK

= General tab:
— Sweep Type: Interpolating

x|
— Frequency Setup = srmleelee r
e Type: Linear Step  [s=em= e =
o Start: 300 kHz ] E
Star |3m | ﬂ Display = - %:z |
e Stop: 6 GHz - : : z j oo | o zxvn
» Step Size: 0.1 GHz et oo, | —
= Click OK -
oK | Cancal |
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Validation Check and Analyze All

Click on HFSS->Validation Check

— If everything passes, close the validation check
window and you are ready to run your simulation

Validation Check: ECE451_tutorial - Microstrip |
; _ o Design Settings
o/ Mictostin o 30 Model

«# Boundaries and Excitations

alidation Check completed. ¥ Mesh Dperations

¥ finalpzis Setup

| «# Optimetrics
o R adiation
Afort | Cloze
Modeler | HFSS Tools  Window Help
X g SoutonType.. w EiEZen| or !
i E| List... :
EDGégaidaumum.. P=9® 0 o & | =
”II‘U‘IndeI s Analyze Al da BF oR g
— —— B EditNotes..,
— HFSS->Analyze All
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Plot S-Parameters

Click on HFSS=> Results=> Create Modal Solution
Data Report->Rectangular Plot

— Select all 4 S-Parameters and click New Report

EY Report: 451_tutorial - micmgtn'pN Report - New Trace(s) u
a— Trace | Families I Families Displa:.rl
Solution: Setupd @ 5
etupl : Sweep ;I Pridgry Sweep: IFreq ;I |||5J| ;I
Domain: SWeep j s Default I = _I
TDFR Cptions ... | =}
v:  |dB(S(INY; dB(S(1,2); dB(S(2, 1)); dB(S(2,2)) St |
Categaory: Quantity: ;I Function:
Variables Pl S(1,1) <none > -
Cutput Variables ang_deqg @
E%_E ang_rad
Y Parameter arg
Z Parameter cang_deq
{{| [ Update Report VSWR cang_rad =
v Realtme Update | Gamma o I 4 [amg] v
Output Variables... | Options... | Mew Report | apply Trace | &dd Trace | Close
k. - -
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Exporting S-Parameters
HFSS—> Results—=>Solution Data—> Export Matrix Data
(#7 Solutions: 451 tutorial - micrastrip /_[-/-;IEIQ

Simulation: I Setupl ;I I Sweep LI

Design Wariation: IEIEIEImiI' trace_H="4mil' trace_L="0" trace_'="114.7mil' waveport_H="115mil" wavepért_w="419mil' J |¢

Profile I Convergence Matrix Data | Mesh Statistics I

v 5 Matix [ Gamma Ewport M atriv Data... I
| r YMatr!H 2o ¥ Display &l Fregs.  Edit Fregs... Equivalent Circuit Export... |

[ Z Matrix =

IMagnitude.-"F'hase[deg;I izl FEssl) I

Pazzivity Tolerance: I.EIEIEI'I

| 5:1:1 | 5:2:1 |

Freq
1.1 [0.013358,  186] [0939075, -BE.2)

B 21 (099075, 562) (00074534, -166)

»

[0 11 (0013702, 154] [0.98986, -618)
P 21 (0ge3e6, 618 (0008686, -177)

11 (0014081, 153) [098897, B7.4)
-2:1 (098897, -674] (0010039, 174]

1:1 (00745068, 151] [038808, -73)

Close |

ECE ILLINOIS ILLINOIS




Reference:

= ECE 451: Planar Transmission Lines by Professor Jose E. Schutt-Aine
= ECE 546: ANSYS HFSS Tutorial by Tianjian Lu
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